Armadilloフォーラム

AWS SDKについて

hanako

2019年9月6日 12時21分

お世話になっております。

pythonでAWSのAmazon S3サービスを利用する為、
botoのインストールを試みたのですが、以下のようなメッセージが表示されました。

$ pip install boto
Collecting boto
Could not find a version that satisfies the requirement boto (from versions: )
No matching distribution found for boto

botoのインストール失敗の原因が分かりません。

Armadilloにインストールしているpythonのバージョンは、2.7.13
pipのバージョンは、9.0.1です。

Armadilloのシステム情報は、以下の通りです。
$ uname -a
Linux armadillo 4.9.112-at2 #6 SMP PREEMPT Fri Dec 28 18:45:25 JST 2018 armv7l GNU/Linux

解決策の情報をご提供頂けますと幸いです。


コメント

at_takumi.ando

2019年9月6日 12時48分

同一環境で確認しましたが、同様のコマンドでbotoのインストールができました。
お使いのArmadillo-IoT G3は、正しくインターネットに接続されていますか?

hanako

2019年9月6日 21時55分

> 同一環境で確認しましたが、同様のコマンドでbotoのインストールができました。
> お使いのArmadillo-IoT G3は、正しくインターネットに接続されていますか?

申し訳ございません。
ネットワーク設定に不備がありました。
インストールできました。
貴重なお時間を頂きまして、申し訳ございません。