Armadilloフォーラム

nanoで日本語を表示したい

fukasawa

2020年10月28日 14時42分

いつもお世話になっております。

以下の環境で日本語を表示させたいのですが、うまくいきません対処方法を教えていただけますでしょうか。

# 環境
Windows 10
TeraTerm 4.102 (送受信 UTF-8、フォントはIPAゴシックに設定)
Armadillo-640
nano 2.7.4 (Compiled options: --disable-libmagic --disable-wrapping-as-root --enable-utf8)

# 現象
日本語を含んだシェルファイルを作成しました。

`cat`コマンドでなら正しく表示されます。

root@armadillo:~# cat test.sh
#!/bin/sh
echo print test text
echo print てすとてきすと

また、実行も正しく表示されます。

root@armadillo:~# ./test.sh
print test text
print てすとてきすと

しかし、nanoでは正しく表示されません。

root@armadillo:~# nano test.sh
 
  GNU nano 2.7.4                    File: test.sh
 
 1 #!/bin/sh
 2 echo print test text
 3 echo print  ^a  ^a^y ^a  ^a  ^a^m ^a^y ^a
 4

# 試してみたこと
LANG=ja_JP.utf8 はやってみましたが、コマンドが見つからないときのメッセージは変わりましたが、nanoには変化はありませんでした。

よろしくおねがいします。

コメント

shkoga

2020年10月28日 15時05分

こんにちは。サムシングプレシャスの古賀と申します。

fukasawaさん:
>以下の環境で日本語を表示させたいのですが、うまくいきません対処方法を教えていただけますでしょうか。
>
># 環境
>Windows 10
>TeraTerm 4.102 (送受信 UTF-8、フォントはIPAゴシックに設定)
>Armadillo-640
>nano 2.7.4 (Compiled options: --disable-libmagic --disable-wrapping-as-root --enable-utf8)

># 試してみたこと
>LANG=ja_JP.utf8 はやってみましたが、コマンドが見つからないときのメッセージは変わりましたが、nanoには変化はありませんでした。

LANG に設定する値を、ja_JP.utf8 ではなく、ja_JP.UTF-8 にすると、どうなるでしょうか?

以下、参考トピックです:
 https://armadillo.atmark-techno.com/forum/armadillo/4262

fukasawa

2020年10月28日 15時20分

コメントありがとうございます。

> LANG に設定する値を、ja_JP.utf8 ではなく、ja_JP.UTF-8 にすると、どうなるでしょうか?
こちらでもやはり、`ja_JP.utf8`の場合と同じ状態です。コマンドが見つからないときのメッセージは変わりましたが、nanoやcatの動作には変化はありません。

fukasawa

2020年10月28日 15時24分

補足情報です。
ファイルの文字コードは確認しました。

root@armadillo:~# file -i test.sh
test.sh: text/x-shellscript; charset=utf-8

at_akihito.irie

2020年10月28日 17時01分

入江です。

1点確認させてください。

> > LANG に設定する値を、ja_JP.utf8 ではなく、ja_JP.UTF-8 にすると、どうなるでしょうか?
> こちらでもやはり、`ja_JP.utf8`の場合と同じ状態です。コマンドが見つからないときのメッセージは変わりましたが、nanoやcatの動作には変化はありません。
上記の動作確認は、以下のコマンドを実行して行ったということでよろしいでしょうか?

[armadillo]# export LANG=ja_JP.UTF-8
[armadillo]# nano test.sh

以上、よろしくお願いいたします。

fukasawa

2020年10月28日 17時48分

> 上記の動作確認は、以下のコマンドを実行して行ったということでよろしいでしょうか?
>

> [armadillo]# export LANG=ja_JP.UTF-8
> [armadillo]# nano test.sh
> 

すいません、`export`を見落としていました。

LANG=ja_JP.UTF-8

export LANG=ja_JP.UTF-8
に変更したところ、無事にnanoで日本語が表示されるようになりました。

あと、以下の方法でもできるようです。
LANG=ja_JP.UTF-8 nano test.sh

ありがとうございました。