Armadilloフォーラム

2038年問題対策

k.miyajima

2016年5月18日 22時37分

よろしくお願いします。
Armadillo460においてNTPを使用したいと思っていますが
Linuxの2038年問題で引っかかっているようで
未来で設定できない年月日が出てしまっています。

2099年までは設定できるようにしたいのですが
現状、通常のやり方では回避できそうもないので
何か良い回避方法がないか考えているのですが
思いつきません。
何か良い案はありませんでしょうか?

よろしくお願いいたします。


コメント

at_ohno

2016年5月20日 15時38分

大野と申します。

2038年問題への対応方法につきましては、Armadillo に限らず、
Linux での対応は、現時点では確定していないと認識しています。

( Linuxカーネルのみの対応ではなく、ライブラリ、アプリケーションも対応が必要な為 )

アプリケーション側で、対症療法的な回避策をお考え頂くか、
もう少し、2038年が近付いて、Linux としての対応方法が決まって来た時に、
標準的な対策方法にアップデートが出来る様に準備しておくのが妥当では無いでしょうか。

なお、「2038」などのキーワードで、検索をしますと、
幾つか過去の具体的な情報のやり取りも見付けられる様です。

串刺し検索システムじろうくん
http://armadillo.atmark-techno.com/search-products#section-search-jiro

検索結果 | 2038
http://armadillo.atmark-techno.com/search/site/2038

例えば、以下のスレッドで詳しい議論がされている様です。

2038年問題について
https://users.atmark-techno.com/node/1114

こちらのスレッドの情報よりも、より詳しい情報がご必要でしたら、
過去ログからの引用等も交えつつ、ご見解を添えて、知りたい事を書くと、
色々と新しい情報やコメントが集まりやすいかと思います。

以上、ご参考となりましたら、幸いです。

k.miyajima

2016年5月25日 22時34分

at_ohno様

本日まで出張だったため、返信が遅くなりました。
申し訳ありません。
ご回答ありがとうございました。
やはり、まだ簡単にはできないのですね。
まずは、おっしゃる通りアプリケーション側で検討してみたいと思います。
ありがとうございました。

> 大野と申します。
>
> 2038年問題への対応方法につきましては、Armadillo に限らず、
> Linux での対応は、現時点では確定していないと認識しています。
>
> ( Linuxカーネルのみの対応ではなく、ライブラリ、アプリケーションも対応が必要な為 )
>
> アプリケーション側で、対症療法的な回避策をお考え頂くか、
> もう少し、2038年が近付いて、Linux としての対応方法が決まって来た時に、
> 標準的な対策方法にアップデートが出来る様に準備しておくのが妥当では無いでしょうか。
>
> なお、「2038」などのキーワードで、検索をしますと、
> 幾つか過去の具体的な情報のやり取りも見付けられる様です。
>
>
> 串刺し検索システムじろうくん
> http://armadillo.atmark-techno.com/search-products#section-search-jiro
>
> 検索結果 | 2038
> http://armadillo.atmark-techno.com/search/site/2038
>
>
> 例えば、以下のスレッドで詳しい議論がされている様です。
>
>
> 2038年問題について
> https://users.atmark-techno.com/node/1114
>
>
> こちらのスレッドの情報よりも、より詳しい情報がご必要でしたら、
> 過去ログからの引用等も交えつつ、ご見解を添えて、知りたい事を書くと、
> 色々と新しい情報やコメントが集まりやすいかと思います。
>
> 以上、ご参考となりましたら、幸いです。
>