Armadilloフォーラム

Armadillo-840が起動できない

k_mizobuchi

2020年6月1日 18時55分

Armadillo840の起動をシリアル通信で確認しようとしたところ、添付のようにメッセージがループして、ログインできませんでした。
https://armadillo.atmark-techno.com/faq/troubleshooting-a440-a420
の手順を確認したところ、5-1. Linux の起動オプションを確認までは正常でした。
次に5-4.Linuxの復旧を行う予定です。
Armadillo849の型式はA8430-B00Zです。
カーネルとユーザーランドイメージは購入時から変更ありません。
このような事象を経験された方はいらっしゃるでしょうか。

ファイル ファイルの説明
ループ画面.JPG

コメント

at_makoto.sato

2020年6月2日 17時23分

佐藤です。

Armadillo-840の「故障かなと思ったら」は以下となります。
https://armadillo.atmark-techno.com/faq/troubleshooting-a840

これまでは正常に動いており、ソフトウェアやハードウェア含めて何も変更していないのに
突然このような現象が発生したということでしょうか。

k_mizobuchi

2020年6月2日 18時30分

佐藤様

> Armadillo-840の「故障かなと思ったら」は以下となります。
> https://armadillo.atmark-techno.com/faq/troubleshooting-a840

840の確認手順を見逃しておりました。ありがとうございます。確認いたします。

> これまでは正常に動いており、ソフトウェアやハードウェア含めて何も変更していないのに
> 突然このような現象が発生したということでしょうか。

本事象発見までの流れは以下の通りです。
購入後、まず保守モードのシリアル通信でhermitブートローダーの書き換えを行いました。
その後、オートブートモードで起動しようとしたところ、上記の現象が見られました。
hermitの書き換えに問題があったのかと考え、標準のhermitイメージファイルで再度書き換えを行いましたが、
同じ現象が起こりました。

なお、hermitのバージョンはv3.11.0で現状の最新版を使用しています。

at_makoto.sato

2020年6月3日 9時31分

佐藤です。

以下の記事を参考にhermitが正しく書き換えられているかどうかご確認ください。
https://armadillo.atmark-techno.com/blog/53/982

間違った領域に書き込まれているかもしれません。
書き込んだときのコマンドをいただけると何かわかるかもしれません。

at_makoto.sato

2020年6月3日 16時38分

佐藤です。

> Armadillo849の型式はA8430-B00Zです。
> カーネルとユーザーランドイメージは購入時から変更ありません。
A8430-B00Zは出荷時にはカーネルとユーザーランドイメージは書き込まれていませんので、
ご自身で書き込んでいただく必要があります。
もし書き込んでいない場合は、書き込んでご使用ください。

各種イメージ及びソースファイルは下記からダウンロードできます。
https://armadillo.atmark-techno.com/armadillo-840/resources/software

イメージの書き換えについては以下を参照ください。
https://manual.atmark-techno.com/armadillo-840/armadillo-840_product_ma…

k_mizobuchi

2020年6月4日 18時02分

佐藤様

カーネルとユーザーランドイメージをシリアル通信で書き込み、
無事に起動できることが確認できました。
ありがとうございました。